Gnome troppo lento?

Da un po di tempo avevo notato come alcune applicazioni lanciate da Gnome (terminale, nautilus..) fossero lentissime ad aprirsi: cose tipo dieci secondi per un terminale, davvero inaccettabile.
La cosa strana è che ciò mi succedeva solo quando non ero connesso in rete.
Frugando in giro, ho trovato questo bug aperto su Launchpad che ha risolto il mio problema.
Tutto nasce dal fatto che alcune applicazioni non riecono a risolvere correttamente localhost (ovvero la macchina su cui state lavorando).
Basta una semplice modifica al file /etc/hosts che aggiunga il vostro hostname (man hostname potrebbe servire), così:

————————————————–
127.0.0.1 localhost hostname

# The following lines are desirable for IPv6 capable hosts
::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts
————————————————-
Adesso tutto va come un missile.

Ah il problema sembra affliggere solo Feisty ed Edgy.

Annunci

Una Risposta to “Gnome troppo lento?”

  1. Grazie mille!!
    Pensavo anche io che fosse colpa della rete ma a me le applicazioni partivano piano anche se ero connesso!

Rispondi

Inserisci i tuoi dati qui sotto o clicca su un'icona per effettuare l'accesso:

Logo WordPress.com

Stai commentando usando il tuo account WordPress.com. Chiudi sessione / Modifica )

Foto Twitter

Stai commentando usando il tuo account Twitter. Chiudi sessione / Modifica )

Foto di Facebook

Stai commentando usando il tuo account Facebook. Chiudi sessione / Modifica )

Google+ photo

Stai commentando usando il tuo account Google+. Chiudi sessione / Modifica )

Connessione a %s...

%d blogger hanno fatto clic su Mi Piace per questo: